Flows delayed

Incident Report for Tekst

Resolved

Systems have scaled up and only a limited set of organizations have some delay.
We continue investigating untill all organizations are up to speed.
Posted Jul 03, 2026 - 08:05 UTC

Investigating

We are investigating delays on automations.
Posted Jul 03, 2026 - 07:35 UTC
This incident affected: Automations.